GLOBAL SITE AUSTRALIAN SITE

Can't install on Linux Debian Jessie | EdWare graphical programming | Forum

Please consider registering
guest

Log In Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Topic3
Can't install on Linux Debian Jessie
January 9, 2017
4:59 am
Sasha
France
New Member
Members
Forum Posts: 1
Member Since:
January 9, 2017
sp_UserOfflineSmall Offline

I tried the online version, but I find it too messy because it’s difficult to have an overview of all the icons hidden on the left, difficult to drag and drop some actions… I thought maybe the offline app gui would be a bit more configurable and I downloaded it. But it won’t start. I think I’ve installed all that was mandatory, and even lots of spare mw apps or libs.

My system is up to date, but I’m not very fluent in Python, so I thought maybe someone here could help. Here what I get as an error:

Traceback (most recent call last):
  File “Téléchargements/edison/edware.py”, line 955, in <module>
    main2(args.filename, args.selected_audio)
  File “Téléchargements/edison/edware.py”, line 930, in main2
    app = BricworksApp(False)
  File “/usr/lib/python2.7/dist-packages/wx-3.0-gtk2/wx/_core.py”, line 8628, in __init__
    self._BootstrapApp()
  File “/usr/lib/python2.7/dist-packages/wx-3.0-gtk2/wx/_core.py”, line 8196, in _BootstrapApp
    return _core_.PyApp__BootstrapApp(*args, **kwargs)
  File “Téléchargements/edison/edware.py”, line 910, in OnInit
    self.frame = Bricworks_frame(None)
  File “Téléchargements/edison/edware.py”, line 146, in __init__
    gui.bric_data.load_brics()
  File “/home/sasha/Téléchargements/edison/gui/bric_data.py”, line 183, in load_brics
    topBricNumber = cp.getint(‘control’, ‘highbric’)
  File “/usr/lib/python2.7/ConfigParser.py”, line 359, in getint
    return self._get(section, int, option)
  File “/usr/lib/python2.7/ConfigParser.py”, line 356, in _get
    return conv(self.get(section, option))
  File “/usr/lib/python2.7/ConfigParser.py”, line 330, in get
    raise NoSectionError(section)
ConfigParser.NoSectionError: No section: ‘control’

January 12, 2017
12:35 am
Willis
New Member
Members
Forum Posts: 1
Member Since:
January 12, 2017
sp_UserOfflineSmall Offline

Hi Sasha,

I initially had the same trouble on Linux Mint. I don’t know if you were doing the same thing I was – running it via the command line from a different directory than the source directory.

I found two solutions.

The simplest was to change directory (cd) to the source directory before issuing the “python edware.py” command.

The second, and more stable fix (I believe), is to edit gui/paths.py to replace the rather fragile “os.getcwd” on line 43.

Old line 43:

    RUN_DIR = os.getcwd()

New line 43:

    RUN_DIR = os.path.dirname(os.path.dirname(os.path.abspath(__file__)))

That worked for me. Edware starts and runs after that.

Hope this helps!

Unfortunately, I’m still unable to download a program to the Edison successfully!

February 4, 2017
2:40 pm
codingforkids
New Member
Members
Forum Posts: 1
Member Since:
February 4, 2017
sp_UserOfflineSmall Offline

Hi

I have used Raspberry Pi 3’s and Linux to run edware software,cool works well but need a bit of customisation to the python scripts.

Ron 

  • Keep up with Edison

    Sign up for our newsletter to get all things Edison delivered straight to your inbox.

  • This field is for validation purposes and should be left unchanged.

Heads up

The Australian Federal Parliament has passed a law that extends goods and services tax (GST) to low value imports of physical goods imported by consumers from 1 July 2018.

This means that all customers purchasing Edison robots and accessories with an Australian shipping address must now pay GST. The GST will be automatically added to your purchase and show as a line item on your invoice.

We've detected that you are in Australia, so we wanted to let you know that we have changed your settings to view our Australian site, which displays GST inclusive pricing.

You can change back to the GLOBAL SITE at any time using the link in the top left of the page.

OK got it!    Take me to the GLOBAL SITE instead

Country

Pin It on Pinterest

Share This