[SOLVED]Sense Light is greyed out under Control | EdWare graphical programming | Forum

Please consider registering

Log In Register

Register | Lost password?
Advanced Search

— Forum Scope —

— Match —

— Forum Options —

Minimum search word length is 3 characters - maximum search word length is 84 characters

[SOLVED]Sense Light is greyed out under Control
February 19, 2018
6:22 pm
New Member
Forum Posts: 2
Member Since:
February 17, 2018
sp_UserOfflineSmall Offline


I’m trying out sensing of light, but the Sense Light icon under the READ group is greyed out. Any hint what I’m missing? So does Read Timer icon.

I defined a variable to hold my light reading; by doing so, it enabled most icons in the Read group but not the Sense Light and Read Timer icons. I appreciate any tip.




– Resolved now. Variable needs to be signed int type (+-32,767). This should be documented elsewhere. 

February 21, 2018
11:12 am
Forum Posts: 180
Member Since:
August 24, 2015
sp_UserOfflineSmall Offline


Yes, both types of variables are needed to use all of the types of Read and Data blocks

  • Keep up with Edison

    Sign up for our newsletter to get all things Edison delivered straight to your inbox.

  • This field is for validation purposes and should be left unchanged.

Heads up

The Australian Federal Parliament has passed a law that extends goods and services tax (GST) to low value imports of physical goods imported by consumers from 1 July 2018.

This means that all customers purchasing Edison robots and accessories with an Australian shipping address must now pay GST. The GST will be automatically added to your purchase and show as a line item on your invoice.

We've detected that you are in Australia, so we wanted to let you know that we have changed your settings to view our Australian site, which displays GST inclusive pricing.

You can change back to the GLOBAL SITE at any time using the link in the top left of the page.

OK got it!    Take me to the GLOBAL SITE instead


Pin It on Pinterest

Share This